Ваша страна: Россия? Да, все верно

Форум » Архив тем » Архив тем техподдержка » IP-камеры видеонаблюдения RVi и IP-видеосерверы RVi (Архив)
Страницы: 1
RSS
RVI-IPC11W + ONVIF протокол, Авторизация по http
 
Здравствуйте!
Имеется следующая видеосистема.
В качестве видеосервера используется ISS SecurOS Lite. Подкключено две камеры RVI-IPC20DN и RVI-IPC21DNL по протоколу ONVIF. Работает система без нареканий. Недавно у Вас вышла новая прошивка для камеры RVI-IPC11W, где включена возможность использования протокола ONVIF.
При подключении RVI-IPC11W с обновленной прошивкой видеопоток не идет, отсутствует сигнал. При детальном рассмотрении данной проблемы выяснилось, что доступ к видеопотоку происходит в несколько этапом:
1) Авторизация по протоколу http
2) При успешной авторизации трансляция видеопотока по протоколу RTSP
пункт (1) по протоколу ONVIF не выполняется.
Чтобы осуществить авторизацию по http можно зайти через браузер Internet Explorer, ввести учетные данные. Начнется трансляция видеопотока. Соответсвенно и по протоколу ONVIF начинается трансляция, видеосервер получает изображение с видеокамеры.
Т. о. трансляция видеоизображения с камеры по протоколу ONVIF на видеосервер происходит только после авторизации через браузер, если используются одинаковые учетные данные на устройсто в видеосервере и при входе через браузер.
Предполагаю что имеется ошибка в прошивке для камеры RVI-IPC11W.  
 
Алексей, добрый день!
Спасибо вам за эксперимент и что подробно всё описали.
Я пробовал на софте AXXON Smart IP - всё ок без авторизации через браузер.
Вопрос такой - ISS (т.к. в руках его не держал, не знаю) поддерживает авторизацию на ONVIF устройстве с паролями не по умолчанию? Другими словами, при добавлении ONVIF устройства он предлагает вам ввести имя/пароль или считает, что они по умолчанию admin/admin и подключается к устройствам с этими данными?
 
Есть возможность ввода имени пользователя и пароля. С IPC20/21 проблем не возникло, при том пользователи не по умолчанию (заведены новые).

TCP    192.168.0.23:54963     192.168.0.102:rtsp     ESTABLISHED  - камера ipc20
TCP    192.168.0.23:54973     192.168.0.103:rtsp     ESTABLISHED -  камера ipc21
TCP    192.168.0.23:55228     192.168.0.100:http     CLOSE_WAIT -  камера ipc11w
изображение не транслируется.
После входа через браузер, замечу что только чере IE или используя расширения для Chrom.

TCP    192.168.0.23:54963     192.168.0.102:rtsp     ESTABLISHED
TCP    192.168.0.23:54973     192.168.0.103:rtsp     ESTABLISHED
TCP    192.168.0.23:55249     192.168.0.100:rtsp     ESTABLISHED  - камера ipc11w
картинка начинает транслироваться
 
Алексей, спасибо ещё раз. Я вас понял. Сейчас проведу эксперимент со своей стороны + попробую узнать, почему может такое возникать... Как будет информация - отпишусь в форум..
 
Спасибо!
Со своеи стороны зарегистрировался на форуме для корректной обратной связи.
 
При использовании ПО  AXXON Smart IP подобной проблемы не возникает. Но, возможно Axxon напрямую использует rtsp, даже если по http не прошло подключение.
Вот что получается на Axxon:
TCP    ASUS:4061  192.168.0.100:http     CLOSE_WAIT
TCP    ASUS:4401  192.168.0.100:554 ESTABLISHED

по http сессия не отвечает.
Страницы: 1
Читают тему

Внимание! Обращаем Ваше внимание на то, что форум работает по принципу премодерации, то есть сообщения публикуются только после одобрения администратором или модератором сайта. Данная мера введена для предотвращения появления спама на форуме.